Dismiss Notice

Register now to be one of the first members of this SharePoint Community! Click here it just takes seconds!

Dismiss Notice
Welcome Guest from Country Flag

Microsoft Edge may fail to launch desktop applications

Discussion in 'Official Microsoft News' started by AxelRMSFT, Mar 27, 2017.

Thread Status:
Not open for further replies.
  1. AxelRMSFT

    AxelRMSFT Guest

    Blog Posts:
    0
    I am Hari from the Internet Explorer Core team. In this blog, we will discuss a scenario involving Microsoft EDGE and Skype for Business.

    SCENARIO: Skype for business does not launch when you click on the “Join the meeting” option from outlook.

    PROCESS: Here are the steps the user normally takes to launch Skype client.

    1. You click on “Join the meeting”
    2. It should invoke Edge (When Edge is configured as default browser which is Windows 10 default configuration), and the Edge would validate the request and handover the meeting operation to Skype for Business and you would join the meeting.

    RESULTS: This might not work in some instances and Microsoft Edge might show the below messages:

    [​IMG]

    [​IMG]

    CAUSE: This issue can occur of the policy setting “Block launching desktop apps associated with a URI scheme” is enabled. This policy setting lets you control whether Windows Store apps can open URIs using the default desktop app for a URI scheme.

    GPO ONLINE LINK: http://gpsearch.azurewebsites.net/#7395 [This link explains the “Block launching desktop apps associated with a URI scheme”]

    Registry Key: HKLMSoftwareMicrosoftWindowsCurrentVersionPoliciesAssociations​

    Value: BlockProtocolElevation​

    Enabled Value:
    decimal: 1

    Disabled Value:
    decimal: 0

    When you remove the policy, the setting allows Edge to launch desktop applications properly irrespective of the URI Scheme. Since Microsoft Edge is a Windows Store application, this particular policy affects its functionality when configured.

    Note: When you configure the policy locally, make sure that “Runtimebroker.exe” is stopped manually to see immediate effect of the policy. However, if you still see the issue please have the machine rebooted so that you can see Edge opening Skype for business.

    This blog has been provided to you by Hariprasad Raghavan!
































    CAUSE: This issue can occur of the policy setting “Block launching desktop apps associated with a URI scheme” is enabled. This policy setting lets you control whether Windows Store apps can open URIs using the default desktop app for a URI scheme.

    GPO ONLINE LINK: http://gpsearch.azurewebsites.net/#7395 [This link explains the “Block launching desktop apps associated with a URI scheme”]

    Registry Key: HKLMSoftwareMicrosoftWindowsCurrentVersionPoliciesAssociations

    Value: BlockProtocolElevation



    Enabled Value:
    decimal: 1

    Disabled Value:
    decimal: 0


    When you remove the policy, the setting allows Edge to launch desktop applications properly irrespective of the URI Scheme. As we know, Edge is a Windows Store application and would be affected by configuring this policy.

    Note: When you configure the policy locally, make sure that “Runtimebroker.exe” is stopped manually to see immediate effect of the policy. However, if you still see the issue please have the machine rebooted so that you can see Edge opening Skype for business.

    Continue reading...
     
Thread Status:
Not open for further replies.

Share This Page

LiveZilla Live Chat Software